Kamis, 31 Oktober 2013

Kumpulan Link Download Delphi RAD Studio XE2

Berjumpa lagi dengan saya Een Pahlefi. Kali ini saya akan share link download program aplikasi desktop yaitu delphi versi lama dan versi terbaru. 















Embarcadero RAD Studio XE3 [Delphi & C++ Bulider] - 3,12 GB

Serial Namber RAD Studio XE2 :
2AAE-E3SSSD-RXN5NE-HACS
3AAD-DCS8KK-RNN4SD-HA2S

Embarcadero RAD Studio XE2 Update 4 Hotfix 1 [Delphi & C++ Bulider] - 2.6 GB

Embarcadero RAD Studio XE2 With Update 3 [ Delphi & C++ Bulider ] - 2.5 GB

Embarcadero RAD Studio XE2 With Update 2 [ Delphi & C++ Bulider ] - 2.4 GB

[Update Only] Update 4 Hotfix 1 For RAD Studio XE2 (252 MB)

[Update Only] Update 3 For RAD Studio XE2 (411 MB)

[Update Only] Update 2 For RAD Studio XE2 (292 MB)

Delphi 2010

Delphi 2009
Password: kppdi

DELPHI 2007 lite

Delphi 7 Lite Edition v 7.3.4.3 Build 01 August 2011

Download Delphi XE2 Update 3 - Lite Version :
https://www.[4]shared.com/archive/sly9tXuf/embarcadero_delphi_xe2_rtm_inc.html

Download Delphi XE2 Update 4 - Lite Version :
https://www.[4]shared.com/archive/ljyubEsn/delphi_xe2_inc_update_4_lite_5.html

Jamu Embarcadero RAD Studio 2010
pass:arradys

RAD Studio 2009 Jamu (Delphi-12)

 Jamu Delphi XE2

Jamu For Delphi XE2 Update 1

Jamu  For Delphi XE2 Update 2
http://www.[4]shared.com/file/j0h7sIKw/AutoPatch_xe2_for_update2_2.html

Jamu For Delphi XE2 Update 3

Jamu For Delphi XE2 Update 4

Semoga Bermanfaat 
Penulis : Een Pahlefi

Tutorial Blokir Website Facebook HTTPS di Mikrotik


Berjumpa lagi dengan saya Een Pahlefi. Sebagai administrator jaringan yang baik kita perlu ada nya sebuah firewall dalam memblokir sebuah situs, dimana pada suatu ketika, kita diminta untuk blokir website disebuah instansi dengan tujuan, agar karyawan tidak membuka facebook dalam waktu jam kerja. Langsung saja, kita amati blokir website HTTP/HTTPS difacebook melalui fitur layer7 di mikrotik.







/ip firewall layer7-protocol

add name=fesbuk regexp="^.+(facebook.com)"



/ip firewall filter

add action=reject chain=forward comment="Blok Facebook di Layer7" disabled=no \
layer7-protocol=fesbuk protocol=tcp reject-with=icmp-port-unreachable


Credit to : https://www.facebook.com/belajar.jaringan
Semoga Bermanfaat 
Penulis : Een Pahlefi 

Rabu, 30 Oktober 2013

Tutorial Routing Mark Tproxy di Mikrotik

Jumpa lagi dengan saya Een Pahlefi. Kali ini saya akan berbagi tutorial cara routing mark port 80 ke proxy external.

Untuk topologi Sesuaikan dengan jaringan anda.
1.ether2-local

2.ether3-proxy
3.ip address PC ubuntu server : 192.168.5.2

Mangle dan Routing TPROXY
-------------------------
/ip firewall mangle
add action=mark-routing chain=prerouting comment="TPROXY ROUTING" disabled=yes dst-port=80 in-interface=ether2-local new-routing-mark=tproxy_rm passthrough=no \
protocol=tcp
add action=mark-connection chain=prerouting disabled=yes dst-port=80 in-interface=ether3-proxy new-connection-mark=tproxy_cm passthrough=yes protocol=tcp \
src-address=!192.168.5.2
add action=mark-routing chain=prerouting connection-mark=tproxy_cm disabled=yes in-interface=!ether3-proxy new-routing-mark=tproxy_rm passthrough=no

/ip route
add disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=192.168.5.2 routing-mark=tproxy_rm scope=30 target-scope=10

Tutorial Mengganti Password Root di Ubuntu 12.04

Bertemu lagi dengan saya Een Pahlefi. Dalam sistem operasi linux, kita mengenal yang namanya hak akses root. Apa itu hak akses root? Hak akses root adalah hak ases paling tinggi kedudukan nya didalam sebuah sistem operasi linux. Dengan kita memegang sebuah akses root, kita bisa leluasa dalam memodifikasi isi didalam sistem sesuai dengan keinginan kita. Untuk itu kita sebagai administrator jaringan khususnya, harus berhati - hati dalam mengingat sebuah password tersebut, agar tidak terjadi hal - hal yang tidak diingkan. baik langsung saja kita mulai tutorial nya.

=======================
1. Login ke Proxy melalui WinSCP/ Putty dengan login yg Anda buat sewaktu install
2. ketik perintah dibawah ini
sudo su [tekan ENTER]
(masukkan password user yang anda buat sewaktu install)
3. ketik lagi
passwd root [tekan ENTER]
ENTER new UNIX password : (masukkan password baru untuk root)
Retype new UNIX password : (masukkan kembali password yang sama)

pastikan muncul tulisan : passwd : password updated successfully


Semoga Bermanfaat.

Tutorial Install Ubuntu Server 12.04

Ketemu lagi dengan saya Een Pahlefi . Kali ini saya akan berbagi tutorial cara install ubuntu server 12.04. Panduan nya mudah sekali, Pertama kali anda harus mempunyai iso file ubuntu server tersebut. Jika belom, anda bisa mendownload nya disini Download Ubuntu 12.04 Server | 32 BIT |

Perhatikan setiap langkah anda, Semoga berhasil



--Instalasi Web Proxy di Ubuntu Server 12.04 part 1 - Instalasi Ubuntu Server 12.04---

Hardware (silahkan disesuaikan)
========
- Proc Core 2 Duo
- HDD 40 GB 
- RAM 1 GB
- CD/DVD RW

Software
========
- Download Ubuntu Server ver 12.04 (iso)
- Download & Install Putty Installer
- Download & Install WinSCP Installer

Persiapan
=========
- Install NIAT terlebih dahulu :-)
- Burn iso file ke CD /DVD
- Set BIOS PC untuk First Boot melalui CD/DVD

Instalasi Ubuntu Server ver 12.04 Lts 
=====================================

Silahkan ikuti petunjuk instalasi dibawah ini. Jumlah cache dan besaran cache sila disesuaikan

---- Configure Language, Location, locales ----
- English [ Tekan Enter ]
- Install Ubuntu Server [ Tekan Enter ]
- English [ Tekan Enter ]
- Other [ Tekan Enter ]
- Asia [ Tekan Enter ]
- Indonesia [ Tekan Enter ]
- United States [ Tekan Enter ]

----Configure the keyboard----
- No [ Tekan Enter ]
- English (US) [ Tekan Enter ]
- English (US) [ Tekan Enter ]

---- Configure the network ----
- Continue [ Tekan Enter ]
- Configure Network Manually [ Tekan Enter ]
- IP Address : 192.168.5.2 [ Tekan Enter ]
- Netmask : 255.255.255.0 [ Tekan Enter ]
- Gateway : 192.168.5.1 [ Tekan Enter ]
- Name Server address : 192.168.5.1 [ Tekan Enter ]
- Hostname : BelajarJaringan [ Tekan Enter ]
- Domain name : [ Tekan Enter ]
- Full name for new user : Belajar Jaringan [ Tekan Enter ]
- username for your account : belajar [ Tekan Enter ]
- choose a password for the new user : passwordku [ Tekan Enter ]
- Re-enter password to verify : passwordku [ Tekan Enter ]
- Encrypt your home directory? : No [ Tekan Enter ]

---- Configure the clock ----
- Jakarta

---- Partition disk ----
- Manual
- SCSI1 (0,0,0) (sda) - 42.9 GB [ Tekan Enter ]
- Create New Partition table on this device ? Yes [ Tekan Enter ]

- pri/log 42.9 GB FREE SPACE [ Tekan Enter ]
- Create a New Partition
- New Partition size : 1 GB [ Tekan Enter ]
- Type for the new partition : Primary [ Tekan Enter ]
- Location for the new partition : Beginning [ Tekan Enter ]
- Pilih Mount point [ Tekan Enter ]
- Pilih /boot - static files of the boot loader [ Tekan Enter ]
- Pilih Mount options [ Tekan Enter ]
- Pilih Noatime [Tekan Tombol Spacebar] [ Tekan Enter ]
- Pilih Bootable flag [ Tekan Enter ]
- Pilih Done setting up the partition [ Tekan Enter ]

- pri/log 41.9 GB FREE SPACE [ Tekan Enter ]
- Create a New Partition
- New Partition size : 2 GB [ Tekan Enter ]
- Type for the new partition : Primary [ Tekan Enter ]
- Location for the new partition : Beginning [ Tekan Enter ]
- Pilih Use [ Tekan Enter ]
- Pilih swap area [ Tekan Enter ]
- Pilih Done setting up the partition [ Tekan Enter ]

- pri/log 39.9 GB FREE SPACE [ Tekan Enter ]
- Create a New Partition
- New Partition size : 19.9 GB [ Tekan Enter ] ------------------> Saya sisakan 20 GB untuk cache dir 
- Type for the new partition : Primary [ Tekan Enter ]
- Location for the new partition : Beginning [ Tekan Enter ]
- Pilih Mount point [ Tekan Enter ]
- Pilih / - the root file system [ Tekan Enter ]
- Pilih Mount options [ Tekan Enter ]
- Pilih Noatime [Tekan Tombol Spacebar] [ Tekan Enter ]
- Pilih Done setting up the partition [ Tekan Enter ]

- pri/log 20 GB FREE SPACE [ Tekan Enter ]
- Create a New Partition
- New Partition size : 20 GB [ Tekan Enter ]
- Type for the new partition : Logical [ Tekan Enter ]
- Location for the new partition : Beginning [ Tekan Enter ]
- Pilih Use [ Tekan Enter ]
- Pilih ReiserFS journaling file system
- Pilih Mount point [ Tekan Enter ]
- Pilih Enter manually [ Tekan Enter ]
- Hapus /Home ganti menjadi /cache1 [ Tekan Enter ]
- Pilih Mount options [ Tekan Enter ]
- Pilih Noatime [Tekan Tombol Spacebar], Pilih Notail [Tekan Tombol Spacebar] [ Tekan Enter ]
- Pilih Done setting up the partition [ Tekan Enter ]

- Pilih Finish partitioning and write changes to disk [ Tekan Enter ]
- Write the changes to disks : Yes [ Tekan Enter ]

--- Configure the package manager ----
- HTTP proxy information (blank for none) : [ Tekan Enter ]

--- Configure tasksel ---
- How do you want to manage upgrade on this system? : No automatic updates [ Tekan Enter ]

--- Software selection ---
- Pilih OpenSSH Server [Tekan Tombol Spacebar] [ Tekan Enter ]

--- Install the GRUB boot loader on a hard disk---
- Install the GRUB boot loader to the master boot record? : Yes [ Tekan Enter ]

--- [!!] Finish the installation ---
- Pilih Continue [ Tekan Enter ]
- keluarkan CD Installer

Notice : Tulisan ini di buat berdasarkan dokumentasi dari teman saya http://www.facebook.com/belajar.jaringan?fref=ts

Tutorial Skrip File Init.d di Squid 2xx

Berjumpa lagi dengan saya Een Pahlefi. Sering kali sewaktu kita compile squid versi 2xx, kita ingin menjalankan file init.d di directory /etc/init.d/squid

Untuk menjalankan services tersebut, kita memerlukan skrip yang ditaroh di file init.d tersebut.

Bagi kalian yang kesulitan untuk menjalankan nya. Silahkan copy paste skrip di bawah ini, dan taroh di /etc/init.d/squid

Notice ini hanya berlaku di versi squid2xx.
Tested 100 Work di Squid 2.7Stable 9






#start file
#! /bin/sh
#
# squid Startup script for the SQUID HTTP proxy-cache.
#
# Version: @(#)squid.rc  2.20  01-Oct-2001  miquels@cistron.nl
#
### BEGIN INIT INFO
# Provides:          squid
# Required-Start:    $local_fs $network
# Required-Stop:     $local_fs $network
# Should-Start:      $named
# Should-Stop:       $named
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Squid HTTP Proxy
### END INIT INFO

NAME=squid
DAEMON=/usr/sbin/squid
LIB=/usr/lib/squid
PIDFILE=/var/spool/squid/logs/$NAME.pid
SQUID_ARGS="-D -YC"

[ ! -f /etc/default/squid ] || . /etc/default/squid

. /lib/lsb/init-functions

PATH=/bin:/usr/bin:/sbin:/usr/sbin

[ -x $DAEMON ] || exit 0

grepconf () {
w=" " # space tab
sq=/etc/squid/squid.conf
# sed is cool.
res=`sed -ne '
s/^'$1'['"$w"']\+\([^'"$w"']\+\).*$/\1/p;
t end;
d;
:end q' < $sq`
[ -n "$res" ] || res=$2
echo "$res"
}

grepconf2 () {
w=" " # space tab
sq=/etc/squid/$NAME.conf
# sed is cool.
res=`sed -ne '
s/^'$1'['"$w"']\+[^'"$w"']\+['"$w"']\+\([^'"$w"']\+\).*$/\1/p;
t end;
d;
:end q' < $sq`
[ -n "$res" ] || res=$2
echo "$res"
}

#
# Try to increase the # of filedescriptors we can open.
#
maxfds () {
[ -n "$SQUID_MAXFD" ] || return
[ -f /proc/sys/fs/file-max ] || return 0
global_file_max=`cat /proc/sys/fs/file-max`
minimal_file_max=$(($SQUID_MAXFD + 4096))
if [ "$global_file_max" -lt $minimal_file_max ]
then
echo $minimal_file_max > /proc/sys/fs/file-max
fi
ulimit -n $SQUID_MAXFD
}

start () {
cdr=`grepconf2 cache_dir /var/spool/$NAME`
ctp=`grepconf cache_dir ufs`

case "$cdr" in
[0-9]*)
log_failure_msg "squid: squid.conf contains 2.2.5 syntax - not starting!"
log_end_msg 1
exit 1
;;
esac

#
    # Create spool dirs if they don't exist.
    #
if [ -d "$cdr" -a ! -d "$cdr/00" ] || [ "$ctp" = "coss" -a ! -w "$cdr" ]
then
log_warning_msg "Creating squid cache structure"
$DAEMON $SQUID_ARGS -z
fi

if [ "$CHUID" = "" ]; then
CHUID=root
fi

maxfds
umask 027
start-stop-daemon --quiet --start \
--pidfile $PIDFILE \
--chuid $CHUID \
--exec $DAEMON -- $SQUID_ARGS < /dev/null
return $?
}

stop () {
PID=`cat $PIDFILE 2>/dev/null`
start-stop-daemon --stop --quiet --pidfile $PIDFILE --name squid
#
# Now we have to wait until squid has _really_ stopped.
#
sleep 2
if test -n "$PID" && kill -0 $PID 2>/dev/null
then
log_action_begin_msg " Waiting"
cnt=0
while kill -0 $PID 2>/dev/null
do
cnt=`expr $cnt + 1`
if [ $cnt -gt 24 ]
then
log_action_end_msg 1
return 1
fi
sleep 5
log_action_cont_msg ""
done
log_action_end_msg 0
return 0
else
return 0
fi
}

case "$1" in
    start)
log_daemon_msg "Starting Squid HTTP proxy" "squid"
if start ; then
log_end_msg $?
else
log_end_msg $?
fi
;;
    stop)
log_daemon_msg "Stopping Squid HTTP proxy" "squid"
if stop ; then
log_end_msg $?
else
log_end_msg $?
fi
;;
    reload|force-reload)
log_action_msg "Reloading Squid configuration files"
$DAEMON -k reconfigure
log_action_end_msg 0
;;
    restart)
log_daemon_msg "Restarting Squid HTTP proxy" "squid"
stop
if start ; then
log_end_msg $?
else
log_end_msg $?
fi
;;
    status)
status_of_proc -p "$PIDFILE" "$DAEMON" squid && exit 0 || exit $?
;;
    *)
echo "Usage: /etc/init.d/$NAME {start|stop|reload|force-reload|restart|status}"
exit 3
;;
esac

exit 0

#EOF


Bank Saya

Pembayaran melalui Bank berikut :

Norek : 013 1 001384 5
An. Een Pahlefi

Norek BRI Rencana : 0623 01 000074-55-6
An. Een Pahlefi

Norek : 0623 01 015938 50 9
An. Een Pahlefi

Norek : 0623 01 015938 50 9
An. Een Pahlefi

Norek : 0623 01 015938 50 9
An. Een Pahlefi

Norek : 0623 01 015938 50 9
An. Een Pahlefi

Google+ Followers

Monitoring

Status Panel Admin
Jam Sekarang
Tanggal
Salam Sapa :
Status Admin :
User : User Online

Popular Posts