Senin, 31 Maret 2014

Tutorial Bypass/Unlimited Bandwith Hacksield Gemscool di Mikrotik

Bertemu lagi dengan saya Een Pahlefi, Disini saya akan berbagi tutorial tentang bypass/unlimited bandwith hacksield gemscool di mikrotik, sebagian orang banyak hanya mendandai koneksi game berdasarkan port game online saja, artinya apa? hanya loss bandwith ketika play game dan didalam room,

Kali ini saya akan membahas ketika anda baru update game, dalam hal ini gemscool. biasanya game pointblank tersebut mengupdate hacksield yg notabene nya masih menggunakan port selain dari port game, al hasil hacksield akan sedikit terlalu lama menunggu, karna file nya sekitar 600kb. kita akan mencari solusi nya dengan cara menandai address yg bertujuan dengan ip hacksield tersebut dan di eksekusi bersamaan dengan mark connection dst port game

ip firewall mangle
add action=mark-connection chain=prerouting comment=TCP1 dst-address-list=nice dst-port=\
    39190,4300,19000,39311,14009-14010,14300-14440,9300,9400,9700,9600,10001-10011,40000 \
    new-connection-mark=game protocol=tcp
add action=mark-connection chain=prerouting comment="Hacksield Kreon" \
    dst-address=49.50.4.0/22 new-connection-mark=game

Logika skripting.

menandai semua koneksi yang lewat tujuan address 49.50.4.0/22 "ip publik kreon, ketika hacksield loading" 
dengan nama connection "game". 
Sesuaikan dengan nama mark connection anda jika sudah ada...










Penulis : Een Pahlefi
Semoga Bermanfaat


Sabtu, 29 Maret 2014

Menggalang Dana Buat Sodara - Sodara Kita yang Gk Mampu Disana.

Panti Asuhan YPITR yang berada di desa tegal rejo, tanjung enim. kondisinya memprihatinkan. Semoga dengan adanya perubahan kepengurusan serta pengawasan oleh masyarakat desa tegal rejo, dapat memperbaiki kondisi ini semua. Semoga juga ALLAH memberikan jalan rizki bagi anak fakir miskin serta yatim piatu, Aamiin.....

******INFORMASI TERAKHIR*******

Untuk bantuan yang dibutuhkan saat ini adalah sarana dan prasarana, makan sehari harinya, dana yang tersedia di kas terakhir saat ini hanya 2 Jt rupiah untuk menghidupi 32 anak di Tanjung Enim, 1 Yang Kuliah di Palembang dan 1 orang di pesantren Bondowoso. untuk makan saat ini kadang dibantu masyarakat sekitar.

Bagi yang ingin membantu dapat datang langsung ke lokasi dengen menemui Ibu Komariah ( 0813 6902 1145 ), Bapak drs. A Latif ( 0813 7342 0164 ) atau Bapak Zulkifli ( 0813 7752 1917 ).
Bagi yang ingin membantu namun tidak dapat datang kelokasi ada rekening atas nama yayasan Bank BRI Cab. Tanjung Enim, No.Rek 5732-01-011297-53-9 a.n Yayasan PITR. 

Jl. H. Rakyan Rt 7a 
Desa: Tegal Rejo
Kecamatan: Lawang Kidul
Kabupaten: Muara Enim
Provinsi: Sumatera Selatan
Kodepos 31713


Kondisi Saudara - Saudara Kita Yang Disana..








Jumat, 28 Maret 2014

Apa itu HTB ?


HTB itu hirarki bertingkat, dimana queue types itu merupakan bagian dari HTB, queue types ini terdiri dari beberapa yaitu PFIFO, SFQ, PCQ, RED, semua peruntukannya ada masing-masing, penempatan queue types ini silahkan sesuaikan kebutuhan masing2
Queueing Disciplines perlu diperhatikan beda antara shaper dan scheduler, dimana shaper akan melakukan drop packet, scheduler akan mengatur packet tersebut agar tidak di drop tapi di distribusikan mundur saat packet itu lagi tidak mencapai max-limit
Tproxy silahkan dilihat di postingan awal2 ada 2 jenis topologi untuk dishape, bisa dikembangkan lebih jauh lagi untuk proxyfarm server, ataupun bentuk topologi lainnya, tujuan tproxy adalah melakukan limitasi based on client ip, agar bandwith tidak bocor dimakan proxy. kesalahan rancangan topologi suatu network dan pemilihan hardware untuk proxy sendiri akan mengakibatkan jaringan tersebut menjadi tidak efisien. penerapan HTB untuk proxy maupun TProxy disesuaikan dengan topologi jaringan. banyak kesalahan seseorang menterjemahkan tentang queueing dimana asumsinya bahwa bisa membatasi bandwith yang masuk ke salah satu interface router, ini kesalahan besar karena router tidak bisa membatasi-nya tapi hanya bisa melakukan drop packet yang berlebihan, yang bisa di atur adalah bandwith yang melewati router bukan bandwith yang masuk ke interface router, ini terkait dengan proses di router itu sendiri yang tidak memungkinkan melimit dari interface lebih jelasnya

interface client-interface router - process (input/forward) - HTB - interface out, pahami baik-baik packet flow ini agar tidak menggantung HTB diatas segala-galanya dan kemudian alih-alih menyalahkan proxy, karena disini saya menggunakan proxy untuk NOC saya dengan bandwith yang masih kecil 10mbps tapi masih bisa ngirimkan sampai 100mbps dan tidak terjadi yang namanya koneksi menjadi lambat karena menggunakan proxy!

konsep dasar HTB mengharuskan ada parent dan child, jika menggunakan cisco ini kadang disebut leaf. HTB tidak akan bekerja dengan baik dengan beberapa kondisi
1. parent max-limit tidak di deklarasikan
2. child limit-at tidak dideklarasikan
3. child max-limit melebihi parent
4. total limit-at child melebihi max-limit parent

untuk settingan yang agan luvin post itu saya tidak tahu siapa yang nge-set karena settingan saya berbeda jauh, untuk settingan saya tidak saya publish disini karena hanya untuk penggunaan internal dan client saya, dan saya tidak pernah menerima setting remote site diluar area jayapura kecuali untuk teman-teman yang saya benar-benar kenal dan itu hanya 1 orang yang pernah saya settingkan gratis. untuk yang mengatakan proxy-nya lambat silahkan gunakan SSD sebagai cache storage dan squid.conf dibenahi sebaiknya built proxy secara manual jangan hanya menggunakan packet-packet yang sudah tersedia, untuk itu diperlukan tuning di system agar proxynya bisa bekerja normal dan bukan justru jadi bottleneck.

Sekian and bye FMI, semoga server ini bisa benar-benar bermanfaat buat teman-teman yang membutuhkan informasi di FMI. no hurt feeling but i just can`t stayed here with dumbass!

Rabu, 26 Maret 2014

Apa itu LoadBalancing PCC

2.1  Metode Load Balancing PCC
            Load Balancing  dengan metode PCC dilakukan dengan mengambil sejumlah field tertentu dari header IP dan membaginya menjadi nilai 32 bit menggunakan algoritma hashing, sesuai dengan artikel yang dapat dilihat pada situs www.wiki.mikrotik.com. Algoritma hashing adalah algoritma untuk mengubah sebuah nilai string atau karakter menjadi sebuah nilai 32 bit yang sudah pasti, sehingga paket dengan header IP yang sama akan menghasilkan nilai hashingyang sama. Parameter yang dapat dijadikan feeder dalam algoritma hashing adalah source-address, destination-address, source-port dan destination-port.
PCC bekerja dengan mengelompokkan koneksi yang keluar dan memasuki router menjadi beberapa kelompok yang ditentukan dari hasil algoritma hashing dan dibagi sesuai dengan jumlah yang sudah ditentukan oleh user. Router akan melakukan pencatatan terhadap jalur gatewayyang dilewati di awal koneksi, sehingga pada paket-paket selanjutnya yang masih berkaitan dengan koneksi awalnya akan dilewatkan  melalui jalur gateway yang sama. Hal ini membuat PCC memiliki kelebihan dibandingkan metode load balancing yang lain, dimana sering terjadi kegagalan yang disebabkan oleh perpindahan gateway. Hal ini juga yang menjadi pertimbangan penulis untuk memilih metode PCC sebagai metode load balancing yang digunakan dalam penelitian ini.
Metode PCC ini tidak melakukan pemecahan paket, melainkan hanya melakukan penandaan pada koneksi sesuai dengan parameter yang diberikan. Routing yang dilakukan adalah membagi beban pada jalur dengan melihat source-address dan destination-address yang disesuaikan dengan hashing table dan pengaturan mangle.

Apa itu LoadBalancing?

2.1  Load Balancing
            Jie Chang et al (2010) menyebutkan bahwa “load balancing adalah sebuah metode untuk memperkuat kapabilitas pemrosesan data yang bertujuan untuk meningkatkan fleksibilitas dan ketersediaan sebuah jaringan”.
Kondisi jaringan yang dinamis dan sering kali tidak terprediksi menyebabkan sebuah algoritma load balancing memiliki kompatibilitas yang tinggi dengan beberapa kondisi jaringan tertentu, sementara algoritma load balancing lainya memiliki kompatibilitas yang lebih rendah pada jaringan tersebut (Kang Xi et al, 2011 : 2).
            Jie Chang et al (2010) dalam penelitiannya menyebutkan beberapa kelebihan implementasi load balancing secara umum, yaitu :
1. Waktu respon akses yang lebih cepat dibandingkan dengan pembagian jalur secara statik, ini dikarenakan beban dibagi ke dalam beberapa jalur sehingga beban pada masing-masing jalur menjadi lebih ringan.
2. Pengaturan untuk mencegah terjadinya penumpukan beban pada salah satu jalur, atau bisa dikatakan pemerataan pembebanan pada masing – masing jalur.
3. Dapat memisahkan dan mengatur jaringan nasional dan internasional agar tidak terjadi saling tarik menarik bandwidth pada jaringan sistem tersebut.
4. Memperkecil kemungkinan terjadinya deadlock trafic yang sering kali terjadi pada perusahaan atau instansi.
5. Redundansi, bilamana salah satu server mati maka koneksi ke jaringan internet dapat tetap berjalan karena menggunakan lebih dari 2 ISP.

            Pemerataan beban yang ada dalam sistem load balancing bukan pemerataan kapasitas yang diberikan dari masing–masing ISP, melainkan pemerataan beban untuk masing–masing client, sebagai contoh jika ada 3 buah ISP yang digunakan pada sistem, dengan kapasitas bandwidthsebagai berikut:
1.    ISP 1 1Mbps
2.    ISP 2 2Mbps
3.    ISP 3 500Kbps

            Yang akan dilakukan sistem load balancing bukan menambahkan menjadi 3.5Mbps, tetapi beban yang dilakukan oleh satu client menjadi sama atau bisa dibilang rata dengan client lainya
            Beberapa algoritma load balancing yang dipakai berdasarkan informasi dari Cisco Service Moduleberjudul Understanding CSM Load Balancing Algorithms dengan nomor dokumen 28580, yang dapat diakses dari situs resmi Cisco, adalah sebagai berikut:
·         Round Robin. Sebuah algoritma pembagian beban secara bergiliran dan berurutan dari satu jalur ke jalur lain.
·         Least Connection. Sebuah algoritma pembagian beban berdasarkan banyaknya koneksi yang sedang dilayani oleh sebuah server. Server dengan pelayanan koneksi yang paling sedikit akan diberikan beban yang berikutnya akan masuk.
·         Weighted Round Robin and Weighted Least Connection. Adalah algoritma pembagian beban secara Round Robin dan Least Connection dengan penambahan parameter performance pembebanan pada masing-masing server.
·         Source and/or Destination IP Hash. Adalah algoritma pembagian beban yang bekerja dengan melakukan pemetaan berdasarkan alamat IP yang ada dalam request yang menuju ke sebuah server. Dalam algoritma ini, parameter subnet mask juga diperhitungkan.
·         Uniform Resource Locator (URL) hashing. Adalah algoritma pembagian beban yang bekerja dengan melakukan pemetaan berdasarkan sebagian atau seluruh URL.
·         Menurut hasil analisa jalur dengan sarana probe. Metode ini menggunakan sarana probe, yaitu pemeriksaan kondisi sebuah jalur dengan mengirimkan sebuah data kosong melalui jalur tersebut. Hasil analisa tersebut kemudian akan menentukan pembagian beban pada jalur yang ada (Kang Xi et al , 2011: 4).
Sementara algoritma load balancing yang digunakan dalam sistem MikroTik routerOS yang dapat dilihat pada situs www.wiki.mikrotik.com adalah:
·           Nth. Adalah algoritma pembagian beban dengan melakukan penandaan pada paket sejumlah nilai yang ditentukan secara berurutan dan pembagian beban dapat dilakukan berdasarkan nilai yang sudah diberikan pada paket.
·           Per Connection Classifier(PCC). Adalah algoritma pembagian beban dengan melakukan penandaan connection sesuai dengan algoritma hashing dimana parameter yang diolah dalam proses hashing tersebut diatur oleh user dan pembagian beban dapat dilakukan berdasarkan nilai pada connectiontersebut.

Metode load balancing yang disebutkan diatas sebetulnya merupakan proses penandaan yang merupakan fitur dalam MikroTik routerOS, dimana kemudian pembagian beban dilakukan berdasarkan hasil pembagian tersebut dengan menggunakan routing policy yang ditentukan oleh user. Keseluruhan proses ini adalah metode load balancing yang ditawarkan oleh MikroTik. 

Rabu, 19 Maret 2014

Tutorial Mengatasi Tidak Bisa Ping di Ubuntu Server




Bertemu lagi dengan  saya Een Pahlefi, Kali ini saya akan memberikan tips dan trik, bagaimana caranya ketika kita di hadapkan dengan sesuatu permasalahan pada ubuntu server.

Bermula saya menemukan di ubuntu server, ping ke luar bisa, tetapi ping kediri sendiri/localhost tidak bisa.
Untuk mengatasi itu ternyata ada kesalahan di ubuntu server.

Pertama anda login ke ubuntu anda, trus edit di bagian nano /proc/sys/net/ipv4/icmp_echo_ignore_all
ubah dari 1 menjadi 0

Dan liat hasil nya.

Rabu, 12 Maret 2014

Selasa, 11 Maret 2014

Tutorial Scripting Mikrotik


Scripting
Scripting
Kata Pengantar
Terkadang kita membutuhkan sebuah atau beberapa rule yang bisa kita jalankan pada kondisi tertentu, jiak berdasarkan waktu, kita mungkin bisa buat scheduler. Akan tetapi, kita misalnya ingin mendisable beberapa rule dengan kriteria tertentu, jika kita lakukan manual tentu akan sangat merepotkan. Nah disini scripting mikrotik dibutuhkan. Pada dasarnya scripting mikrotik tidak jauh beda dengan scripting bahasa lainnya, misal php atau lainya. Konsepnya masih sama bahkan jika dilihat sekilas dia seperti menggunakan bahasa Perl, hanya mungkin beda kata atau karakter. Jika sebelumnya Anda pernah belajar pemrograman, tentu scripting di mikrotik bukan hal yang sulit. Dan pada tulisan ini, saya akan menyampaikan beberapa dasar scripting di mikrotik.
Struktur Script
Scripting di RouterOS bisa dilakukan dalam beberapa baris, dan nantinya script akan diekseskusi satu demi satu. Struktur scripting pada command line RouterOS seperti berikut :
[prefix] [path] command [uparam] [param=[value]] .. [param=[value]]
Keterangan :
[prefix] = “:” atau “/” karakter yang mengindikasikan bahwa command merupakan ICE (karakter yg mengindikasikan global command) atau path. Karakter ini, .bisa dibutuhkan, bisa juga tidak
[path] = Path yang bersifat relatif untuk menentukan menu level. Bisa dibutuhkan, bisa juga tidak
command = Prrintah yang tersedia pada level menu tertentu.
[uparam] = parameter tanpa nama, harus dispesifikasikan terlebih dahulu jika command membutuhkannya.
[params] = Urutan parameter yang sudah dikenal yang memiliki nilai tertentu.
*Umm..saya juga sedikit bingung maksud keterangan diatas, kalau Anda ahli bahasa inggris, disarankan baca wiki.
Setiap akhir dari command pasti diakhiri dengan tanda “;” atau dengan baris baru, dan terkadang akhir command tidak butuh keduanya. Well, agak rumit memang, seperti ketika Anda mendengar jawaban “terserah”.
Single command yang berada di dalam (), [] or {}  tidak membutuhkan karakter tanda akhir command. Akhir dari command ditentukan dari seluruh script, contoh :
:if ( true ) do={ :put "tralala" }
Jika ada command kedua di dalam sebuah command, maka harus diampit tanda “[]“. Contoh :
:put [/ip route get [find gateway=1.1.1.1]];
Anda bisa lihat rule diatas memiliki 3 perintah :
  1.  :put = menampilkan nilai di terminal
  2. /ip route get  = mencari rule route
  3. find gateway=1.1.1.1 = menentukan rule route yang memiliki parameter gateway=1.1.1.1
Membuat Komentar
Komentar diawali dengan tanda hashtag atau “#” kemudian dikuti karekter komentar. Perlu diketahui, tanda “#” yang berada didalam variable string tidak akan dianggap sebagai komentar, namun dianggap bagian dari string. Contoh penguunaan command :
# Ini adalah komentar
# Komentar yang tidak baik, ada spasinya.
:global a; # Ini juga bukan cara menulis komentar yang baik
:global myStr "Di-reject Jenita Janet # ini bukan komentar, tapi string"
Membuat Script Beda Baris
Jika dirasa terlalu panjang atau memang ingin dibuat beberapa baris perintah, perintah bisa digabungkan dengan menambahkan karakter backslash “/” di ujung. Perlu diketahui, tanda backflash, tidak dapat digunakan pada komentar. Contoh penerapan :
:if ($a = true \
and $b=false) do={ :put “$a $b”; }
:if ($a = true \ # bad comment
and $b=false) do={ :put “$a $b”; }
# comment \
continued – invalid (syntax error)
Spasi (Daerah Kosong)
Seperti pada bahasa pemrograman pada umumnya, spasi ini kadang dibutuhkan, kadang tidak boleh digunakan, dan kadang harus digunakan, tergantung syntax apa spasi ini si impementasikan. Spasi tidak boleh digunakan pada systax ’<parameter>=’,  ’from=’ ,’to=’ , ‘step=’,  ’in=’,  ’do=’ , ‘else=’. Contoh penerapan
#contoh yang salah :
:for i from = 1 to = 2 do = { :put $i }
#contoh yang benar :
:for i from=1 to=2 do={ :put $i }
:for i from= 1 to= 2 do={ :put $i }
#contoh yang salah
/ip route add gateway = 3.3.3.3
#contoh yang benar
/ip route add gateway=3.3.3.3
Variable dan Cakupannya
Berdasarkan cakupanya, ada 2 jenis variable, :local dan :global. Globar mencakup seluruh script dan bisa dikenali dalam beberapa baris perintah, sedangkan local, dia hanya akan dikenali dalam satu struktur perintah. Variable global tidak bisa didefinisaikan didalam local scope. Contoh sederhana penerapan variable:
[admin@MikroTik] > :local myVar a;
[admin@MikroTik] > :put $myVar
syntax error (line 1 column 7)
Debugging
Sebenarnya ini hanya sekedar Tips & Trik saja, namun bagi saya debungging atau mencari kesalahan script adalah dengan menampilkan value. Biasanya kalau saya belajar java, saya tinggal tulis “print”, dengan VB “msgbox”.  Nah, di mikrotik, caranya dengan perintah “:put”.
[admin@MikroTik] > :put "Haloo"
Haloo
[admin@MikroTik] >
Bagi saya pribadi :put ini sangat bermanfaat dimana saya bisa menelusuri kesalahan dengan menampilkan masing – masing value pada beberapa perintah. Bisa juga untuk menampilkan Variable.
[admin@MikroTik] > :local MyVar "Halo Dunia"; :put $MyVar
Halo Dunia
[admin@MikroTik] >
Operasi Matematika
Mikrotik juga support untuk melakukan perhitungan matematika.
OperatorKeteranganContoh
“+”Menjalankan perintah penjumlahan:put (3+4);
“-”Menjalankan perintah pengurangan:put (1-6);
“*”Menjalankan perintah pengalian:put (4*5);
“/”Menjalankan perintah Pembagian:put (10 / 2); :put ((10)/2)
“-”Menjadikan bilangan negatif{ :local a 1; :put (-a); }
Operasi Logika
OpearatorKeteranganContoh
“!” , “not”logical NOT:put (!true);
“&&” , “and”logical AND:put (true&&true)
“||” , “or”logical OR:put (true||false);
“in”:put (1.1.1.1/32 in 1.0.0.0/8);
Perintah Perulangan
CommandSyntaxKeterangan
do..while:do { <commands> } while=( <conditions> ); :while ( <conditions> ) do={ <commands> };Menjalankan perintah sampai menemukan kondisi tertentu
for:for <var> from=<int> to=<int> step=<int> do={ <commands> }Menjalankan perintah sesuai jumlah perulangan yang ditentukan.
foreach:foreach <var> in=<array> do={ <commands> };Menjalankan perintah pada setiap element yang ada didalam daftar perintah.
Contoh Penggunaan Perintah Diatas :
Do While :
{:global i 10; :do {:put $i; :set i ($i - 1);} while (($i < 11) && ($i > 0))};
For :
:for i from=1 to=100 step=37  do={:put ($i)}
Foreach :
:foreach i in=[/interface find type=ether ] do={:put ("+--" . [/interface get $i name])};
Perintah Kondisi
Perintah yang dijalankan pada kondisi tertentu bisa dibuat dengan peintah “If”, dengan struktur perintah :
:if(<condition>) do={<commands>} else={<commands>} <expression>
Contoh Penggunaan :
{
:local myBool true;
:if ($myBool = false) do={ :put "value is false" } else={ :put "value is true" }
}
Command Lainnya
CommandSyntaxKeteranganContoh
/Kembali ke root menu.
..Kembali ke satu menu level.
?Menampilkan perintah yang tersedia.
global:global <var> [<value>]Mendefinisikan variable global.:global myVar “something”; :put $myVar;
local:local <var> [<value>]Mendefinisikan variable local.{ :local myLocalVar “I am local”; :put $myVar; }
beep:beep <freq> <length>Membuat bunyi beep.
delay:delay <time>Berhenti selama waktu yang ditentukan.
put:put <expression>Menampilkan argumen pada console.
len:len <expression>Menampilkan panjang string atau jumlah elemen array.:put [:len "length=8"];
typeof:typeof <var>Menampilkan tipe data variable.:put [:typeof 4];
pick:pick <var> <start>[<end>]Mengambil nilai substring atau elemen array, jika tidak ada informasi berapa panjang range yang akan diambil, maka hanya akan diambil 1 saja.:put [:pick "abcde" 1 3]
log:log <topic> <message>Menulis pesan ke dalam log, dengan topics yang tersedia adalah “debug, error, info and warning”.:log info “Hello from script”;
time:time <expression>Menentukan interval waktu dalam menjalankan perintah.:put [:time {:for i from=1 to=10 do={ :delay 100ms }}];
set:set <var> [<value>]Memberikan nilai pada suatu variable.:global a; :set a true;
find:find <arg> <arg> <start>Menemukan nilai berdasarkan kriteria string atau array.:put [:find "abc" "a" -1];
environment:environment print <start>Mencetak informasi variable yang diketahui.:global myVar true; :environment print;
terminalPerintah terminal.
error:error <output>Menampilkan error pada console dan berhenti menjalankan script.
parse:parse <expression>Menyimpan perintah pada sebuah variable, bisa dijadikan sebagai fungsi.:global myFunc [:parse ":put hello!"];$myFunc;
resolve:resolve <arg>Menampilkan ip address dari sebuah DNS:put [:resolve "www.mikrotik.com"];
toarray:toarray <var>Mengubah variable ke array
tobool:tobool <var>Mengubah variable ke boolean
toid:toid <var>Mengubah variable ke internal ID
toip:toip <var>Mengubah variable ke IP address
toip6:toip6 <var>Mengubah variable ke IPv6 address
tonum:tonum <var>Mengubah variable ke integer
tostr:tostr <var>Mengubah variable ke string
totime:totime <var>Mengubah variable ke time
Sebenarnya masih banyak yang bisa dipelajari dari scripting mikrotik ini, akan tetapi artikel pada kali ini cukup sampai disini saja. Selain capek nulisnya, kebetulan penulis merasa cukup mengantuk. Jika Tuhan menghendaki, artikel mengenai scripting ini akan dilanjutkan pada judul yang baru. Terima kasih.

Bank Saya

Pembayaran melalui Bank berikut :

Norek : 013 1 001384 5
An. Een Pahlefi

Norek BRI Rencana : 0623 01 000074-55-6
An. Een Pahlefi

Norek : 0623 01 015938 50 9
An. Een Pahlefi

Norek : 0623 01 015938 50 9
An. Een Pahlefi

Norek : 0623 01 015938 50 9
An. Een Pahlefi

Norek : 0623 01 015938 50 9
An. Een Pahlefi

Google+ Followers

Monitoring

Status Panel Admin
Jam Sekarang
Tanggal
Salam Sapa :
Status Admin :
User : User Online

Popular Posts