Senin, 27 Januari 2014

Tutorial Firewall Mikrotik Bloking Rule

/ip firewall filter
add action=drop chain=input comment="Drop Invalid connections" \
connection-state=invalid disabled=no
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="Port scanners to list " \
disabled=no protocol=tcp psd=21,3s,3,1
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="NMAP FIN Stealth scan" \
disabled=no protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="SYN/FIN scan" disabled=no \
protocol=tcp tcp-flags=fin,syn
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="SYN/RST scan" disabled=no \
protocol=tcp tcp-flags=syn,rst
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="FIN/PSH/URG scan" disabled=\
no protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="ALL/ALL scan" disabled=no \
protocol=tcp tcp-flags=fin,syn,rst,psh,ack,urg
add action=add-src-to-address-list address-list="port scanners" \
address-list-timeout=2w chain=input comment="NMAP NULL scan" disabled=no \
protocol=tcp tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg
add action=drop chain=input comment="Dropping port scanners" disabled=no \
src-address-list="port scanners"
add action=accept chain=input comment="Allow Established connections" \
connection-state=established disabled=no
add action=accept chain=input comment="Allow Related connections" \
connection-state=related disabled=no
add action=accept chain=input comment="Allow ICMP from LOCAL Network" \
disabled=no protocol=icmp src-address-list=Local-NET
add action=accept chain=input comment="Allow ICMP from PROXY Network" \
disabled=no protocol=icmp src-address-list=Proxy-NET
add action=accept chain=input comment="Allow Input from LOCAL Network" \
disabled=no src-address-list=Local-NET
add action=accept chain=input comment="Allow Input from PROXY Network" \
disabled=no src-address-list=Proxy-NET
add action=drop chain=input comment="Drop everything else" disabled=no
add action=drop chain=forward comment="Drop Invalid connections" \
connection-state=invalid disabled=no
add action=jump chain=forward comment="Bad packets filtering" disabled=no \
jump-target=tcp protocol=tcp
add action=jump chain=forward comment="" disabled=no jump-target=udp \
protocol=udp
add action=jump chain=forward comment="" disabled=no jump-target=icmp \
protocol=icmp
add action=drop chain=tcp comment="deny SMTP" disabled=no dst-port=25 \
protocol=tcp
add action=drop chain=tcp comment="deny TFTP" disabled=no dst-port=69 \
protocol=tcp
add action=drop chain=tcp comment="deny RPC portmapper" disabled=no dst-port=\
111 protocol=tcp
add action=drop chain=tcp comment="deny RPC portmapper" disabled=no dst-port=\
135 protocol=tcp
add action=drop chain=tcp comment="deny NBT" disabled=no dst-port=137-139 \
protocol=tcp
add action=drop chain=tcp comment="deny cifs" disabled=no dst-port=445 \
protocol=tcp
add action=drop chain=tcp comment="deny NFS" disabled=no dst-port=2049 \
protocol=tcp
add action=drop chain=tcp comment="deny NetBus" disabled=no dst-port=\
12345-12346 protocol=tcp
add action=drop chain=tcp comment="deny NetBus" disabled=no dst-port=20034 \
protocol=tcp
add action=drop chain=tcp comment="deny BackOriffice" disabled=no dst-port=\
3133 protocol=tcp
add action=drop chain=tcp comment="deny DHCP" disabled=no dst-port=67-68 \
protocol=tcp
add action=drop chain=tcp comment="deny P2P" disabled=no p2p=all-p2p
add action=drop chain=udp comment="deny TFTP" disabled=no dst-port=69 \
protocol=udp
add action=drop chain=udp comment="deny PRC portmapper" disabled=no dst-port=\
111 protocol=udp
add action=drop chain=udp comment="deny PRC portmapper" disabled=no dst-port=\
135 protocol=udp
add action=drop chain=udp comment="deny NBT" disabled=no dst-port=137-139 \
protocol=udp
add action=drop chain=udp comment="deny NFS" disabled=no dst-port=2049 \
protocol=udp
add action=drop chain=udp comment="deny BackOriffice" disabled=no dst-port=\
3133 protocol=udp
add action=accept chain=icmp comment="limit packets 5/secs" disabled=no \
icmp-options=0:0-255 limit=5,5 protocol=icmp
add action=accept chain=icmp comment="limit packets 5/secs" disabled=no \
icmp-options=3:0 protocol=icmp
add action=accept chain=icmp comment="limit packets 5/secs" disabled=no \
icmp-options=3:3 limit=5,5 protocol=icmp
add action=accept chain=icmp comment="limit packets 5/secs" disabled=no \
icmp-options=3:4 limit=5,5 protocol=icmp
add action=accept chain=icmp comment="limit packets 5/secs" disabled=no \
icmp-options=8:0-255 limit=5,5 protocol=icmp
add action=accept chain=icmp comment="limit packets 5/secs" disabled=no \
icmp-options=11:0-255 limit=5,5 protocol=icmp
add action=drop chain=icmp comment="Drop other icmp packets" disabled=no
add action=accept chain=forward comment="Allow Established connections" \
connection-state=established disabled=no
add action=accept chain=forward comment="Allow Forward from LOCAL Network" \
disabled=no src-address-list=Local-NET
add action=accept chain=forward comment="Allow Forward from PROXY Network" \
disabled=no src-address-list=Proxy-NET
add action=drop chain=forward comment="Drop everything else" disabled=no

Kamis, 23 Januari 2014

Penggunaan: refresh_pattern

  1. Penggunaan: refresh_pattern [-i] regex min persen max [opsi]
  2.  
  3.  
  4. Secara default, ekspresi reguler adalah CASE-SENSITIVE. Untuk membuat mereka case-insensitive, gunakan opsi-i.
  5.  
  6.  
  7. 'Min' adalah waktu (dalam menit) suatu objek tanpa kejelasan waktu kadaluwarsa harus dipertimbangkan fresh.
  8. Nilai yang disarankan adalah 0, nilai-nilai yang lebih tinggi dapat menyebabkan aplikasi dinamis akan membuat bingung cache kecuali perancang aplikasi
  9. telah mengambil tindakan yang tepat.
  10.  
  11.  
  12. 'Persen' adalah persentase dari objek umur (waktu sejak terakhir lama modifikasi) obyek tanpa kejelasan waktu kadaluwarsa akan dianggap baru.
  13.  
  14.  
  15. 'Max' adalah batas atas bagaimana objek panjang tanpa kejelasan waktu kadaluwarsa akan dianggap baru.
  16.  
  17.  
  18. Opsi: override-expire
  19.  
  20.                  override-lastmod
  21.                  reload-into-ims
  22.                  ignore-reload
  23.                  ignore-no-store
  24.                  ignore-must-revalidate
  25.                  ignore-private
  26.                  ignore-auth
  27.                  max-stale=NN
  28.                  refresh-ims
  29.                  store-stale
  30.  
  31. override-expire memaksa minimal usia bahkan jika server mengirim kejelasan waktu kadaluwarsa (misalnya, dengan Expires: header or Cache-Control: max-age).
  32. Ini akan MELANGGAR standar HTTP. Mengaktifkan fitur ini bisa membuat Anda bertanggung jawab atas masalah yang terjadi.
  33. Catatan: override-expire tidak memaksa untuk merefresh cache - hanya memperluas
  34. Freshness / min. Jika server mengembalikan waktu expired lebih lama dari waktu yang anda tentukan, Squid masih akan mempertimbangkan
  35. cachenya fresh.
  36.  
  37. override-lastmod memaksa min usia bahkan pada objek cache yang baru tercache.
  38.  
  39. reload-into-ims perubahan klien no-cache atau `` reload''
  40. meminta cache entri untuk masuk ke dalam permintaan bersyarat menggunakan If-Modified-Since and/or If-None-Match headers,
  41. asalkan cache entri memiliki Last-Modified dan/atau ETag header yang kuat.
  42. Melakukan hal ini MELANGGAR standar HTTP.
  43.  
  44. ignore-reload mengabaikan klien no-cache atau `` reload'' header.
  45. Mengaktifkan fitur ini bisa membuat Anda bertanggung jawab atas masalah yang terjadi.
  46.  
  47. ignore-no-store mengabaikan setiap ``Cache-control: no-store'' header yang diterima dari server.
  48. Melakukan hal ini MELANGGAR standar HTTP. Mengaktifkan fitur ini bisa membuat Anda bertanggung jawab atas masalah yang terjadi.
  49.  
  50. ignore-must-revalidate mengabaikan setiap ``Cache-Control: must-revalidate`` header yg diterima dari server.
  51. Melakukan hal ini MELANGGAR standar HTTP. Mengaktifkan fitur ini bisa membuat Anda bertanggung jawab atas masalah yang terjadi.
  52.  
  53. ignore-private mengabaikan setiap ``Cache-control: private'' header yg diterima dari server.
  54. Melakukan hal ini MELANGGAR standar HTTP. Mengaktifkan fitur ini bisa membuat Anda bertanggung jawab atas masalah yang terjadi.
  55.        
  56. ignore-auth cache tanggapan terhadap permintaan dengan otorisasi,
  57. ignore-auth caches merespon permintaan dengan autorisasi, seolah olah server asli telah mengirim ``Cache-control: public'' diresponse header.
  58. Melakukan hal ini MELANGGAR standar HTTP. Mengaktifkan fitur ini bisa membuat Anda bertanggung jawab atas masalah yang terjadi.
  59.  
  60. refresh-ims akan membuat squid menghubungi server asal.
  61. ketika klien mengeluarkan permintaan If-Modified-Since.
  62. Ini akan memastikan bahwa klien akan menerima versi terbaru jika tersedia.
  63.  
  64. store-stale penyimpanan/cache akan tetap merespon jika tidak mendapatkan kejelasan  
  65.                 refresh atau validasi yg tersedia (contoh., Last-Modified or an ETag)
  66.                 atau jika mereka sudah expired/basi. secara default, Squid tidak akan mencache respon seperti itu karna biasanya response seperti itu tidak dapat digunakan kembali.
  67.                 Catatan response seperti itu akan basi/expired secara default.
  68.  
  69. max-stale=NN memberikan nilai maximal factor refresh. Squid tidak akan melayani objek yang lebih basi/expired dari ini bahkan jika itu gagal memvalidasi objek.
  70. Default: gunakan max_stale limit global.
  71.  
  72. Pada dasarnya objek cache adalah:
  73.  
  74.                 FRESH Jika Berakhir < sekarang, selain itu STALE/basi(expired)
  75.                 STALE Jika usia > max
  76.                 FRESH Jika lm-factor < persen, selain itu STALE/basi(expired)
  77.                 FRESH Jika usia < min
  78.                 selain itu STALE/basi(expired)
  79.  
  80. Garis refresh_pattern diperiksa dalam urutan yang tercantum di sini.
  81. Entri pertama yang cocok digunakan. Jika tidak ada entri yang cocok secara default akan digunakan.
  82.        
  83. Catatan, Anda harus menghapus semua baris contoh setingan squid jika Anda ingin
  84. untuk mengubah. Pengaturan standar / contoh config hanya aktif jika tidak ada yang digunakan.

Rabu, 22 Januari 2014

Tutorial Subtitle Editor dengan Visual Basic

Dim MyIndex As Integer, VArr As Variant, VBarr As Variant

Private Sub CmdUpDown_Click(Index As Integer)
 Dim n
 n = Val(texts.Text)
 If MyIndex = 3 Then
  If Index = 1 And n < 999 Then
   texts.Text = n + 1
  End If
 Else
  If Index = 1 And n < 59 Then
   texts.Text = n + 1
  End If
 End If
 If Index = 0 And n > 0 Then
  texts.Text = n - 1
 End If
End Sub

Private Sub Command1_Click()
 GetSrtFile
End Sub

Private Sub GetSrtFile()
 CommonDialog1.CancelError = True
 On Error GoTo ErrHandler
 CommonDialog1.Flags = cdlOFNHideReadOnly
 CommonDialog1.Filter = "Subtitle (*.srt)|*.srt"
 CommonDialog1.FilterIndex = 2
 CommonDialog1.ShowOpen
 Text1.Text = CommonDialog1.FileName
 Call GetSample(1)
 Exit Sub
ErrHandler:
 Exit Sub
End Sub

Private Sub GetSample(myNumb As Double)
Dim xLine, MyLine, SubArr
 Open Text1.Text For Input As #1
 Do
  Line Input #1, xLine
  If Val(xLine) = myNumb Then
    TextSrt(0).Text = xLine
   Line Input #1, MyLine
    Call Splitter(MyLine, " --> ")
    TextSrt(1).Text = VBarr(0)
    TextSrt(2).Text = VBarr(1)
    Call Splitter(TextSrt(1).Text, ",")
    SubArr = VBarr(0)
    textedit(3).Text = VBarr(1)
    Call Splitter(SubArr, ":")
    textedit(0).Text = VBarr(0)
    textedit(1).Text = VBarr(1)
    textedit(2).Text = VBarr(2)
    TextSrt(3).Text = ""
   Do
    Line Input #1, MyLine
    TextSrt(3).Text = TextSrt(3).Text & MyLine & vbCrLf
   Loop Until MyLine = ""
   Exit Do
  End If
 Loop
 Close #1
End Sub

Private Sub Splitter(MyArg, Delim As String)
 VBarr = Split(MyArg, Delim)
End Sub

Private Sub Command4_Click()
Dim n As Double
If Text1.Text = "" Then
Else
n = Val(TextSrt(0).Text) + 1
Call GetSample(n)
End If
End Sub

Private Sub Command6_Click()
Dim mya, myb, sto, st1, st2, st3
Set fso = CreateObject("Scripting.FileSystemObject")
On Error Resume Next
'EKSEKUSI
 If Text1.Text = "" Then
 Else
  MsgBox "Membuat SRT FILE ORiginal", vbOKOnly, "PROCESS"
  mya = Len(Text1.Text)
  myb = Mid(Text1.Text, 1, (mya - 4))
  myb = myb & "(original).srt"
  FileCopy Text1.Text, myb
  Open myb For Input As #1
  Open Text1.Text For Output As #2
  Do Until EOF(1)
   Line Input #1, sto
    If Mid(sto, 14, 3) = "-->" Then
    Call Splitter(sto, "-->")
    st1 = VBarr(0)
    st2 = VBarr(1)
    st1 = bagiempat(st1)
    st2 = bagiempat(st2)
    st1 = Val(st1) + Val(Text5.Text)
    st2 = Val(st2) + Val(Text5.Text)
    Call konversi(Val(st1))
    st1 = nol(VArr(0)) & ":" & nol(VArr(1)) & ":" & nol(VArr(2)) & "," & nolz(VArr(3))
    Call konversi(Val(st2))
    st2 = nol(VArr(0)) & ":" & nol(VArr(1)) & ":" & nol(VArr(2)) & "," & nolz(VArr(3))
    sto = st1 & " --> " & st2
    End If
   Print #2, sto
  Loop
  Close #1
  Close #2
  MsgBox "COMPLETE"
 End If
End Sub

Private Sub textedit_Change(Index As Integer)
Dim myvalue
 If Index = 3 Then
  Select Case Len(textedit(Index).Text)
   Case 0
    textedit(Index).Text = "000"
   Case 1
    textedit(Index).Text = "00" & textedit(Index).Text
   Case 2
    textedit(Index).Text = "0" & textedit(Index).Text
  End Select
 Else
  Select Case Len(textedit(Index).Text)
   Case 0
    textedit(Index).Text = "00"
   Case 1
    textedit(Index).Text = "0" & textedit(Index).Text
  End Select
 End If

 myvalue = kalkulasi(Val(textedit(0).Text), Val(textedit(1).Text), Val(textedit(2).Text), Val(textedit(3).Text))
 Text4.Text = myvalue
 myvalue = Val(Text4.Text) - Val(Text2.Text)
 If myvalue < 0 Then
  Label4.Caption = "MAJU"
  myvalue = Mid(myvalue, 2)
 ElseIf myvalue > 0 Then
  Label4.Caption = "MUNDUR"
 Else
  Label4.Caption = "-"
 End If
Text5.Text = myvalue
 Call konversi(Val(Text5.Text))
Text6.Text = nol(VArr(0)) & ":" & nol(VArr(1)) & ":" & nol(VArr(2)) & "," & nolz(VArr(3))
End Sub

Private Sub bagidua(MyText)
 Dim myval1, myval2
  Call Splitter(MyText, " --> ")
   myval1 = VBarr(0)
   myval2 = VBarr(1)
   myval1 = bagiempat(myval1)
   myval2 = bagiempat(myval2)
End Sub
Private Function bagiempat(myval)
Dim val1, val2, val3, val4, val5, value1, value2
  Call Splitter(myval, ",")
   val5 = VBarr(0)
   val4 = VBarr(1)
  Call Splitter(val5, ":")
   val1 = VBarr(0)
   val2 = VBarr(1)
   val3 = VBarr(2)
 bagiempat = kalkulasi(Val(val1), Val(val2), Val(val3), Val(val4))
End Function

Private Function nol(myval)
 If Len(myval) = 0 Then
  nol = "00"
 ElseIf Len(myval) = 1 Then
  nol = "0" & myval
 Else
  nol = myval
 End If
End Function

Private Function nolz(myval)
 If Len(myval) = 0 Then
  nolz = "000"
 ElseIf Len(myval) = 1 Then
  nolz = "00" & myval
 ElseIf Len(myval) = 2 Then
  nolz = "0" & myval
 Else
  nolz = myval
 End If
End Function

Private Function kalkulasi(val1 As Double, val2 As Double, val3 As Double, val4 As Double)
 val1 = val1 * 3600000
 val2 = val2 * 60000
 val3 = val3 * 1000
 kalkulasi = val1 + val2 + val3 + val4
End Function

Private Sub konversi(myval As Double)
Dim v1, v2, v3, v4
 v4 = Right(myval, 3)
 myval = (myval - Val(v4)) / 1000
 If myval >= 3600 Then
  v1 = Fix(myval / 3600)
  myval = (myval - (v1 * 3600))
 End If
 If myval >= 60 Then
  v2 = Fix(myval / 60)
  myval = (myval - (v2 * 60))
 End If
 v3 = myval
 VArr = Array(v1, v2, v3, v4)
End Sub

Private Sub textedit_GotFocus(Index As Integer)
Dim n
 MyIndex = Index
 texts.Enabled = True
 Select Case Index
  Case 0
   n = "hours"
  Case 1
   n = "minutes"
  Case 2
   n = "seconds"
  Case 3
   n = "miliseconds"
 End Select
 Label3.Caption = n
 texts.Text = Val(textedit(Index).Text)
End Sub

Private Sub texts_Change()
 textedit(MyIndex).Text = texts.Text
End Sub

Private Sub texts_KeyPress(KeyAscii As Integer)
 Dim Ky
 Ky = KeyAscii
 If (Ky >= 48 And Ky
  If MyIndex = 3 Then
   If Len(texts.Text) < 3 Or Ky = 8 Then
    KeyAscii = Ky
   Else
    KeyAscii = 0
   End If
  Else
   If Len(texts.Text) < 2 Or Ky = 8 Then
    If Val(texts.Text) < 6 Or Ky = 8 Then
     KeyAscii = Ky
    Else
     KeyAscii = 0
    End If
   Else
    KeyAscii = 0
   End If
  End If
 Else
  KeyAscii = 0
 End If
End Sub

Private Sub TextSrt_Change(Index As Integer)
If Index = 2 Then
 Text2.Text = bagiempat(TextSrt(1).Text)
 Text3.Text = bagiempat(TextSrt(2).Text)
End If
End Sub

Private Sub TextSrt_Click(Index As Integer)
On Error Resume Next
If Index = 1 Then
    Call Splitter(TextSrt(1).Text, ",")
    SubArr = VBarr(0)
    textedit(3).Text = VBarr(1)
    Call Splitter(SubArr, ":")
    textedit(0).Text = VBarr(0)
    textedit(1).Text = VBarr(1)
    textedit(2).Text = VBarr(2)
End If
End Sub

Senin, 13 Januari 2014

Perbandingan Metode Koneksi PB Garena


Dokumen ini hanya sekedar menunjukkan perbandingan masing-masing metode koneksi yang bisa digunakan untuk bermain PB GArena.
  • WTFast
Kelebihan
  1. Terdapat Banyak server untuk koneksi
Kekurangan
  1. Free 30 hari
  2. Setting masing2 PC klien
  3. Trial habis, harus beli / cara lain.
  • Proxifier
Kelebihan
  1. Koneksi lebih simple
Kekurangan
  1. Setting masing2 PC klien
  2. Harus cari proxy yang nyala dan stabil
  3. proxy tidak selamanya UP.
  4. Ribet update 1-1 PC klien jika terjadi perubahan
  • VPN
Kelebihan
  1. Setting di Router untuk seluruh PC klien
  2. relatif lebih stabil
  3. tidak ribet setting per PC klien
  4. tidak ribet ganti settingan
Kekurangan
  1. Relatif berbayar

Sekian menurut pendapat Saya, Kurang lebih mohon dibantu mengoreksinya. :)

Minggu, 12 Januari 2014

DOWNLOAD ACTIVATOR WIN 8.1 ENTERPRISE BUILD 9600 RTM FINAL

INSTRUCTIONS :
For video tutorial >> Download
1.REMOVE installation key first using "Winact 1.4.1" (Right Click "Run as administrator")
- Choose "options" and "unistall product key".

2. Run "A9600E-Enterprise-x86.exe" (for 32-Bit) or go to the folder "A9600E-Enterprise-x64"
and run "A9600E.bat" (for 64-Bit) (Right click "Run as administrator") and wait.
- Check equipment if Properties "Windows is activated".

3.Run "My WCP watermark Editor" (Right Click "Run as administrator")
- Check the box "Remove all wathermark" and click on "Apply new settings"

4. Restart the PC
-Done !, your Windows 8.1 RTM ENTERPRISE is now activated.

Bank Saya

Pembayaran melalui Bank berikut :

Norek : 013 1 001384 5
An. Een Pahlefi

Norek BRI Rencana : 0623 01 000074-55-6
An. Een Pahlefi

Norek : 0623 01 015938 50 9
An. Een Pahlefi

Norek : 0623 01 015938 50 9
An. Een Pahlefi

Norek : 0623 01 015938 50 9
An. Een Pahlefi

Norek : 0623 01 015938 50 9
An. Een Pahlefi

Google+ Followers

Monitoring

Status Panel Admin
Jam Sekarang
Tanggal
Salam Sapa :
Status Admin :
User : User Online

Popular Posts